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Introduction
WinLogView is a graphical log review application that allows you to load ASCII log files 
created by WinLog, MegaTune, and other ASCII comma delimited log files. This guide 
will explain the WinLogView software and its operation. 

Requirements
WinLogView is a WIN32 application, which means that it should run on Windows 98, 
ME, 2000, XP and Vista.  The software will run using as little system memory as 32MB 
(depending on the OS requirements of course). WinLogView will also run successfully a 
CPU as slow as an Intel Pentium 90mhz. A 640x480 display is the minimum 
recommended display resolution for WinLog, while it is able to run in lower resolutions, 
some of the configuration dialogs may not fit on the screen.

Installing WinLogView
Installing the software is automatically done when you install WinLog, no further steps 
are required to install WinLogView

The WinLog installation procedure created a shortcut on your start menu under the 
WinLog program group. If at any point you need to uninstall the software, an uninstall 
program is provided under the WinLogView program group that will completely remove 
the software from your PC.

Starting WinLogView
Normally, you will launch WinLogView from WinLog by selecting the “File->Open Log 
File” option. In addition, you can manually launch WinLogView independently of 
WinLog by clicking on its shortcut in the start menu under the WinLog program group. 

Once WinLogView starts you will be displayed with the WinLogView title screen, and 
be given an option to register the software. If you don’t want to register at the moment, 
wait a couple of seconds and click the “Continue” button when it is displayed.

If you have already registered your copy of WinLogView the title screen will not be 
displayed, and you will immediately be taken to the WinLogView main window.
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Registering WinLogView
If you're feeling generous and find that the WinLogView software is useful, please 
consider registering your software. You'll get a couple of really useful features, and will 
help motivate me to continue improving the software! :-) WinLogView itself is a direct 
result of the user support the TEWBLOG received over the years, and I hope to continue 
that with WinLog and WinLogView!

Registration is a simple procedure, when you first start WinLogView you are given the 
option to register for a couple of seconds, if you click the “Register” button during this 
time the “Enter Registration Code” screen will be displayed. If you already have a code, 
you can enter your name and the registration code. If not, click the button at the bottom 
of the dialog to learn how to get a code. If you have a registration code for WinLog, you 
can use that same code to register WinLogView.

Once you’ve entered your name, and the registration code (both should be entered exactly 
as provided in the registration email you will receive), click the "OK" button, and if all is 
well, you will be prompted that the software has been registered.
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Getting Started
Depending on how you start WinLogView, you’ll be presented with either a file selection 
box, or a graph will be displayed. If you are starting WinLogView from a shortcut, or 
Windows start menu, WinLogView will display the following dialog to select a log file:

By changing the Files of type option, you can also cause the file open dialog to display 
MegaTune type log files (with the .xls extension, not to be confused with Microsoft Excel 
spreadsheet files, which WinLogView will NOT open!)

After selecting a file, you will be returned to the WinLogView main screen, and 
WinLogView will attempt to display the contents of the log file. If no fields have been 
selected that are contained in the opened log file, WinLogView will prompt you to select 
fields to display.

WinLogView has two different display modes, Graph mode, and Matrix mode. Graph 
mode is a standard two dimensional graph view that can plot many simultaneous graphs. 
The Matrix mode is a “Spreadsheet” type display that plots up to 3 different graph fields, 
two in the x and y axis, and a third in the cells of the spreadsheet.
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Following are of each of the different modes:

WinLog in “Graph” mode:

WinLog in “Matrix” mode:
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Following, we’ll discuss the different graph modes that WinLogView can display.

Graph Mode
When WinLogView is in Graph mode, it displays a standard two dimensional graph plot. 
The plot may contain many simultaneous fields, each overlaid on the same graph.

At the top of the graph, you’ll find the legend, which shows you the name of each of the 
fields, its corresponding color, and the value of the field that is currently under the cursor. 
As the cursor moves around the graph, the values under each of the field names will be 
updated to reflect the value of the field at that location in the log file.

At the right side of the graph is the scale. The scale shows you the range of graph that has 
the corresponding color lines. Clicking on any of the scale values will display the field 
configuration dialog for the specific field, allowing you to modify the display settings.

WinLogView v1.0 - 8 -



The graph can be “zoomed” in and out to specific ranges of data, making it easier to 
analyze.

This can be done via a variety of methods. A selection can be marked using the mouse by 
clicking and dragging a range of data, once the range is selected, you can right click the 
mouse, and select the “Zoom In” option (or select the zoom in icon on the toolbar, or the 
zoom in view->zoom in menu). The selected area will now take up the entire width of the 
graph window. In addition, you can zoom in to any point by either double-clicking the 
point, or pressing the numeric ‘+’ key at any point the cursor is located. 

The graph is zoomed out using the same methods as zooming in, to use the keyboard to 
zoom out, press the numeric ‘-‘ key. In addition, you can zoom out to the full range of the 
log file using the View->Zoom Out Full option. 

When the graph has been zoomed in, it will be larger than the width of the window, 
because of this, you will now have the ability to “scroll” the graph to the left or right. 
You can use the scroll bar at the bottom of the window to do this, or simply use the 
cursor keys, when the cursor is at the right or left of the window, the data will be scrolled 
to either the right or left and show the data prior to or after the displayed data.

At the bottom of the graph display, there is an additional field, which is user 
configurable. Usually this field is used to show things like the sample number or time at a 
given position in the log file. As you zoom in/out and pan around in the log file, you’ll 
notice that these numbers change, reflecting the new position in the file.
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Configuring the graph display
The graph display is a highly configurable display, allowing you to choose which fields 
from the log file are graphed, and how they are graphed. To configure the graph display, 
first, load a log file (File->Open Log), then select the View->Fields menu item (when in 
graph mode). You will be presented with the Graph Fields screen.

The graph fields screen contains the following items:

Available Fields
This is the list of fields that are available in the currently opened log file. One or more of 
these can be selected for graphing in the graph view. This is done by selecting the 
field(s), then clicking the arrow pointing to the right. Once the arrow has been clicked, 
the selected fields will be moved to the “Graphed Fields” box, and removed from the 
“Available fields” box.

Graphed Fields
This is the list of fields that will be graphed by WinLogView. Fields not in this box will 
not be graphed. Once a field has been put into this box, WinLogView will automatically 
assign it a new color, and you will be able to configure how the field is displayed by 
using the Configure Field button.

X Axis Field
This is the field that will be used as the X Axis scale at the bottom of the screen. 
Generally, you’ll want to use something like a “sample time” or a “sample number” to 
configure this field (if available).  By default, WinLogView will display the sample 
number for the X Axis scale.
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Configure Field
Selecting this button while a graphed field is highlighted will allow you to edit the 
display settings for a specific field. Once clicked, the “Field Configuration” is displayed:

The Field configuration dialog allows you to modify the display settings for a graphed 
field. The following settings are available:

Field Name
Contains the name of the field that will be displayed.

Y Axis Range
The settings in this box determine how the field data will be vertically scaled and 
displayed. The following options are available:

Manual
This option gives you the ability to specify the range of data that you would like the 
display. When selected, the scale of the data will be fixed to the Y Min and Y Max 
settings below. Zooming etc will have no effect on the scale.

Auto Range (on initial display)
This option allows you to have WinLogView calculate the range of data that is contained 
in the log file. When a log file is opened, WinLogView will scan the file for the range of 
the specified field, and fix the Y axis range to the file range. Zooming etc will have no 
effect on the scale.

Auto Range (recalc when zoomed)
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This option forces WinLogView to rescan the field data every time you zoom in or out, 
and set the range of the data according to the currently visible fields. 

Y Axis Scale
This option lets you decide how much of the Y axis the field should take up. Specified in 
percent, it allows you to compress the data so that it does not take up the full height of the 
graph. For example, setting this value to 50% would cause the graph to only take up half 
of the available vertical graph space.

Y Axis Offset
This option allows you to offset the data vertically in the graph display space. This can be 
helpful if you have lots of graphs that attempt to plot data in the same region on the 
display. It is possible to “shift” the data to a clear area in the display using this setting. 
When combined with the Y Axis scale, it can make it much easier to read when many 
graphs are being plotted.

Below is an example of a graph with Y axis scales and offsets.

As you can see, the three graphs do not overwrite each other because they have been 
scaled and offset in the display area, making the graph easier to read.
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Line Color
The Line Color option chooses the color of the lines that will be used to plot the field. By 
default, WinLogView attempts to choose a discrete color for each field. When the color 
box is clicked, the user has the ability to modify the color that will be used for the field. 
Clicking the color box display the color chooser dialog:

When you’re done choosing a color, click the “OK” button to return to the field 
configuration dialog.

Number of decimal places to display
This setting defines the precision that will be displayed both in the Y axis scale for the 
field, and the current cursor value in the legend at the top of the screen. Setting this value 
to zero causes the decimal point and the trailing numbers to be truncated.

When you have finished configuring the field, select the “OK” button, and you will be 
returned to the Graph Fields dialog.
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Graph Files
Once a graph has been defined, you have the ability to save them for future use on other 
data logs, without having to re-define the graph settings every time. Following we will 
discuss the Graph file operations.

Saving Graph Files
After you have finished defining your graph settings, you can choose to save them to a 
file. This is done by selecting the File->Save Graph option from the main screen. Once 
selected, the “Save As” dialog will be displayed:

After you enter a filename and Select the “Save” button, the graph configuration will be 
saved to the filename specified. After a file has been saved, WinLogView will 
automatically open the graph configuration file the next time WinLogView is opened, 
and apply it to log files that are displayed.
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Loading Graph Files
Occasionally, you’ll have different ways that you’d like to look at the data in your log 
files. WinLogView has the ability to display log files using the pre-defined graph settings 
that you have previously saved. To load a graph configuration file, select the File->Open 
Graph menu item from the main window. A file selection screen will be displayed:

Once you have selected the graph file that you would like to use, select the “Open” 
button, and you will be returned to the WinLogView main screen, if a log file is currently 
loaded, it will be redisplayed with the new graph settings.

Occasionally, fields that were defined with the graph settings will not be available in the 
log file, WinLogView deals with this by not displaying fields that are not available in the 
log file. You’ll also notice that if you go into the configuration for the graph, that there 
may be “grayed” out fields in the “Graphed Fields” list. These are fields that were 
defined in the graph configuration, but are not present in the currently loaded log file.
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Matrix Mode
The matrix graph mode allows you to display data in a “spreadsheet” style gauge that 
plots values based on two input fields, and a resulting field based on the intersection of 
the two input fields. Along each of the axes (vertical and horizontal), an input field is 
selected, for each of the cells in the “spreadsheet”, the third input field is displayed. This 
type of display can be useful in things like air/fuel ratio tuning maps, where one axis can 
be manifold pressure, one can be RPM, and the cells can be the air/fuel ratio.

Cell Information
Hovering the mouse pointer over a cell for a short period of time will cause a small 
popup window to appear which contains information about that cell. In this window you 
will find the data ranges of the cell, the minimum and maximum sample values collected 
for the cell, and the number of samples collected (again for the specific cell). Moving the 
window to a different cell (or elsewhere) will clear the popup.
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Configuring the Matrix Graph
To configure the matrix display, first, load a log file (File->Open Log), then select the 
View->Fields menu item (when in matrix mode). You will be presented with the 
Configure Matrix Graph screen.

At the top of the dialog is the “Title” field. This is an optional title that will be displayed 
at the top of the matrix display, and if omitted, will not be displayed.

Below the title, are 3 tab style configuration pages, each corresponds to one of the three 
fields that will be used to populate the matrix.

Cell Settings:
The “Cells” tab defines the field that will be used to populate the cells on the matrix 
gauge. 
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The “Field” setting defines the field that will be displayed in the cells of the 
“spreadsheet”. It is configured by clicking the “…” button at the right side of the field 
setting. When the “…” button is clicked, the “Select Field” screen will be displayed.

The select field screen displays the list of fields that are available in the currently open 
log file. Select the field that you would like to use for the cells, and click the “OK” 
button. Once clicked, you will be returned to the “Configure Matrix Graph” screen.

 The “Minimum number of samples for a cell to be displayed” field allows you to choose 
the number of samples that must be present in the log file before displaying a value. This 
helps keep the clutter out of the display when there are insufficient samples to generate a 
valid display.

The “Discard samples with values less than” field allows you to specify a minimum 
sample field value. When the selected field is less than this value, it will not be added to 
the graph (this can help keep erroneous or irrelevant data out of the matrix graph).

The “Discard samples with values more than” field allows you to specify a maximum 
sample field value. When the source field is more than this value, it will not be added to 
the graph (this can help keep erroneous or irrelevant data out of the matrix gauge). Note 
that this field defaults to zero, and if not set might result in data not being displayed!!!
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The “Precision” field allows you to select the number of digits following the decimal 
point in the cell display values. Setting this value to zero will omit the display of the 
decimal point and the trailing precision.

The “Display” setting allows you to choose the matrix gauge display mode, the following 
three settings are available:

Average – The samples from the log file will be averaged and displayed in the cells
Minimum – The minimum value from the log file will be displayed in the cells
Maximum – The maximum value from the log file will be displayed in the cells.

The Cell Color Range fields control the background color that will be used to display 
cells.  The color will be interpolated between the mimimum and maximum defined cell 
values using the specified colors for the span. The following fields are available:
Start Color Cell Value – The value of the starting sweep color. Cell values less than the 
specified value will all be displayed using the starting sweep color.
End Color Cell Value – The value of the ending sweep color. Cell values greater than 
the specified value will all be displayed using the ending sweep color. 

The starting and ending colors can be changed by clicking on the color boxes, and 
selecting a color. If the start and end colors are the same, the selected color will always 
be used as the background color for the cell.
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Row/Column Settings:
The row/column setting tabs define the x and y axis data fields. The settings for rows and 
columns are identical, so both will be discussed here.

The “Field” setting works as in the cell configuration tab, simply select the “…” button to 
select the field for the row/column.

The “number of cells” field defines the number of rows/columns in each axis. Adding 
additional rows/cols to the graph is accomplished by making this number larger or 
smaller.

The “Cell Ranges" field defines the range of each row/column in the graph. The ranges 
do not need to be contiguous (i.e., there may be gaps in the ranges for areas that you are 
not interested in). Overlapping cell ranges will only display values in the first cell range 
that is defined. To modify a cells range, simply double click on the one of the ranges in 
the list, and specify the minimum and maximum values for that cell. Double clicking an 
item presents the Row/Col range dialog:
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The “Range Min” field defines the minimum value for the specified row/col. (the current 
row/col is displayed in the title bar of the dialog)

The “Range Max” field defines the maximum value for the specified row/col (the current 
row/col is displayed in the title bar of the dialog)

Pressing the “OK” button will return you to the configure matrix graph dialog.

If you need to delete one or more rows/columns, simply change the “Number of Cells” 
field, and the number of fields will be updated accordingly.

The “Precision” field allows you to select the number of digits following the decimal 
point in the row/column display values. Setting this value to zero will omit the display of 
the decimal point and the trailing precision.

The “Display” setting allows you to choose the matrix gauge display mode, the following 
three settings are available:

Range – The range (both min and max values) of row/column values will be displayed in 
the header.
Minimum – The minimum value for the cell will be displayed in the header
Maximum – The maximum value for the cell will be displayed in the header.
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Matrix Files
Once a matrix has been defined, you have the ability to save them for future use on other 
data logs, without having to re-define the matrix settings every time. Following we will 
discuss the Matrix file operations.

Saving Matrix Files
After you have finished defining your matrix settings, you can choose to save them to a 
file. This is done by selecting the File->Save Matrix option from the main screen. Once 
selected, the “Save As” dialog will be displayed:

After you enter a filename and Select the “Save” button, the matrix configuration will be 
saved to the filename specified. After a file has been saved, WinLogView will 
automatically load the matrix configuration file the next time WinLogView is opened, 
and apply it to log files that are displayed.
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Loading Matrix Files
Occasionally, you’ll have different ways that you’d like to look at the data in your log 
files. WinLogView has the ability to display log files using the matrix settings that you 
have previously saved. To load a matrix configuration file, selected the File->Open 
Matrix menu item from the main window. A file selection screen will be displayed:

Once you have selected the matrix configuration file that you would like to use, select the 
“Open” button, and you will be returned to the WinLogView main screen, if a log file is 
currently loaded, it will be redisplayed with the new matrix settings.

Occasionally, fields that were defined with the matrix settings will not be available in the 
log file. WinLogView will warn you if the current matrix configuration will not work 
correctly with the loaded log file, and will give you a chance to go and change the matrix 
configuration.

WinLogView v1.0 - 23 -



WinLogView Menus

WinLogView has two main menus, the File and View menus.

File Menu

The “File” menu allows you to access the “File” functionality of WinLogView. It has the 
following items:

Open Log
Open a log file for viewing in the current view mode (either Graph or Matrix). The file 
will be opened using the current graph or Matrix Configuration.

Open Graph/Open Matrix
Open a graph or matrix configuration file and apply it to the currently loaded log file.

Save Graph/Save Matrix
Save the current graph or matrix configuration to a file. WinLogView will default to this 
configuration file the next time it is loaded.
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Save Selection to new log
Selecting this option will save the currently highlighted area of a graph to a new log file. 
This is useful if you have an extremely large log file that you’d like to extract data from. 
First, select the area of the graph that you are interested in (by clicking and dragging with 
the mouse), then select this menu item. You will be presented with a file selection dialog:

After entering a filename, and selecting the “Save” button, your data will be saved to the 
new log file. Note that this option is available only when you are in Graph mode.
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Export Graph Image
Selecting this option will export the currently displayed graph to an image file. (Windows 
.bmp format). This allows you to easily share graph images with those that might not 
have WinLogView. After selecting the menu item, the Export Graph Image dialog will be 
displayed:

After entering the File name, and clicking the “Save” button, the graph image will be 
saved to the specified filename. Note that this option is available only when you are in 
Graph mode.

Exit
Closes WinLogView

View Menu

The View menu gives you access to different display modes and configuration options 
available in WinLogView
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Fields
The fields option displays either the Graph Fields or Configure Matrix Graph dialogs, 
depending on your current display mode.

Zoom In
Available only in Graph mode, causes the graph to zoom into either the currently selected 
area, or to zoom in at the current cursor position.

Zoom Out
Available only in Graph mode, causes the graph to zoom out at the current cursor 
position.

Zoom Out Full
Available only in Graph mode, causes the graph to zoom out to the full extent of the log 
file, displaying the complete log file on the graph.

Graph Mode
Sets the display mode to Graph Mode.

Matrix Mode
Sets the display mode to Matrix Mode

Large Toolbar
Enables and disables the large toolbar display. The large toolbar display is used to 
facilitate easier data review when using touch screen style displays.

Small Toolbar

In order from left to right the following toolbar icons are defined:
- Open a log file
- Save graph or matrix configuration file
- Zoom In
- Zoom Out
- Configure Fields
-
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Large Toolbar

In order from left to right the following large toolbar icons are defined:
- Open a log file
- Open a graph/matrix configuration file
- Zoom In
- Zoom Out
- Zoom Out Full
- Set graph mode
- Set matrix mode
- Exit WinLogView
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