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Introduction
WinLog is a generic logging software platform that enables the user to connect multiple 
non-related logging devices simultaneously, and log data from them to both the screen 
and a file for later review. In addition, WinLog provides a standard architecture in which 
drivers can be easily developed to support new devices. This guide will explain the 
WinLog software and its operation. For details about the specific logging hardware/driver
and its operation, please visit the manufacturers site.

Requirements

WinLog is a WIN32 application, which means that it should run on XP and higher.  The 
software will run using as little system memory as 32MB (depending on the OS 
requirements of course). WinLog will also run successfully a CPU as slow as an Intel 
Pentium 90mhz. As you add logging devices and gauges to the dashboard, the memory 
and CPU requirements will increase. A 640x480 display is the minimum recommended 
display resolution for WinLog, while it is able to run in lower resolutions, some of the 
configuration dialogs may not fit on the screen.

Installing WinLog

Installing the software is a simple process. After downloading and saving the installation 
program on your PC, simply execute the program (WINLOGSETUP.EXE) and you will 
be guided through the installation. 

First, you’ll need to select a folder in which to copy the files.
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Once the folder has been selected, you’ll need to choose the start menu folder that 
WinLog will be installed to.

A shortcut will be created on your start menu under the WinLog program group. If at any 
point you need to uninstall the software, an uninstall program is provided under the 
WinLog program group that will completely remove the software from your PC.

Starting WinLog

Once the WinLog software has been installed, it will create a shortcut on your start menu 
under the WinLog program group. To start WinLog simply click on the shortcut under 
the start menu. 

Once WinLog starts you will be displayed with the WinLog title screen, and be given an 
option to register the software. If you don’t want to register at the moment, wait a couple 
of seconds and click the “Continue” button when it is displayed.

If you have already registered your copy of WinLog the title screen will not be displayed,
and you will immediately be taken to the WinLog main window.
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Registering WinLog

If you're feeling generous and find that the WinLog software is useful, please consider 
registering your software. You'll get a couple of really useful features, and will help 
motivate me to continue improving the software! :-) WinLog itself is a direct result of the
user support the TEWBLOG received over the years, and I hope to continue that with 
WinLog!

Registration is a simple procedure, when you first start WinLog you are given the option 
to register for a couple of seconds, if you click the “Register” button during this time the 
“Enter Registration Code” screen will be displayed. If you already have a code, you can 
enter your name and the registration code. If not, click the button at the bottom of the 
dialog to learn how to get a code.

Once you’ve entered your name, and the registration code (both should be entered exactly
as provided in the registration email you will receive), click the "OK" button, and if all is 
well, you will be prompted that the software has been registered.

WinLog v1.1 6



Getting Started
When you initially start WinLog, you’ll be presented with an empty main screen that will
be referred to as the “dashboard”. The dashboard is a user configurable area that you can 
use to monitor data coming back from your logging device in real-time. The main screen 
looks as follows:

At the top of the main screen is the menu, which contains the File, Edit, View and help 
menu items. At the bottom of the screen, you’ll find the status bar. At the left side of the 
status bar, prompts appear notifying you of the current status of WinLog. At the right side
of the status bar are two boxes, one notifying you that you are/are not currently logging, 
and the current number of warnings that have been triggered. We’ll discuss the warnings 
later.
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Device Setup

The first thing that you should do after starting WinLog for the first time is to setup your 
logging device(s). This is done by selecting the “View->Device Configuration” menu 
item from the main screen. Once the menu option has been selected, you will be 
presented with the “Configure Logging Devices” screen.

This screen displays all of the currently installed logging devices. It is the place where 
you can add, remove, and reconfigure the devices that WinLog will communicate with. In
some instances, the logging device can be a simple driver, and not have any hardware 
(such as the WinLog Performance Monitor), in other cases, hardware and software are 
required to make the device work. Up to 64 devices can be installed simultaneously in 
WinLog. 

Generally speaking, you will connect your logging device to the system before adding 
and configuring the WinLog device driver, but some drivers may be exceptions to this. 
After the hardware is connected, select the “Add…” button, and you will be presented 
with the “Select Device” dialog:
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This dialog allows you to select a device to add to the WinLog Device Driver list. 
WinLog installs with a few standard drivers, if your driver is in the list, simply select it, 
and select the “OK” button.  If the driver is not in the list, you’ll need to either download 
the driver from the manufacturer, or install it from its driver disk. In either case, select the
“Have Disk…” button, and select the driver file. (Windows 7/8/10 and later versions, see
important notes below prior to clicking the “Have Disk...” button!!!) 

Once the driver has been selected, it will be added to the “Select Device” list. If this is 
your first time using WinLog, you might just want to try using the “Sample Driver” to get
accustomed with WinLogs operation. The sample driver will generate a couple of test 
fields that will allow you to define dashboards and experiment with logging.
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Adding a new driver to WinLog in Windows 7 and higher

Starting in Windows 7, WinLog requires you to be in “Administrator” mode in order to 
add a new driver to WinLog. To add a new driver, use the following steps:
1) Close any currently running versions of WinLog
2) Under the “Windows” menu, find the WinLog application, and right click it.
3) Select the “More” and “Run as administrator” option.
4) Select “Yes” when prompted to allow the application to make changes to your device.
5) Select the “View→Device Configration” option
6) Select the “Add” button
7) Select the “Have Disk...” button
8) Locate the driver .dll file and select it, click the “Open” button
9) You should get a “Driver install successful” message, click OK
10) Click “Cancel” (Do NOT configure the newly installed driver at this point!!!)
11) Click “Cancel”
12) Close WinLog
13) Run Winlog normally (not as an administrator)
14) View→Device Configuration
15) Select the “Add...” button and select the new driver that was installed in the prior 
steps
16) Configure the driver as needed.
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Driver Configuration

Once the driver has been selected on the “Select Device” dialog, and you have pressed 
“OK”, you will be presented with the drivers configuration options. See the drivers 
documentation for details about configuring the specific options of your driver. When 
you’ve completed configuring your driver, you will be returned to the “Configure 
Logging Device Settings” dialog, where your newly installed driver should now be 
present. 

Clicking the small “+” icon next to the driver name will expand the list of “fields” which 
are available for the driver. Selecting a field, and clicking the “Settings…” button will 
bring up the “Configure Field” dialog. (Note that selecting a device and then clicking the 
settings button will bring up configuration settings for the device, not the field!)

The Configure Field dialog allows you to configure aspects of each field that a logging 
device supports. At the top of the dialog, you’ll find the device name, and the name that 
the device assigns to the field. 

The “Log this field” option decides whether or not you want the field included in the log 
file when you log data. This setting has no effect on the dashboard. If this check box is 
checked, the field will be included in the log file, otherwise it will be omitted.

The “Field Name” setting allows you to provide a name to field. This name will be used 
in the log file when referring to the field, and also used by WinLog when identifying the 
field name. If multiple instances of the same device have been installed, WinLog will 
modify the field name so that you don’t have duplicate field names in your log file. Be 
sure to avoid duplicate field names between your devices, since it will be hard to 
determine which one is which in the log file!
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The “Field Precision” setting defines how many digits you would like displayed 
following the decimal point in fractional numbers. If you set this value to zero, no 
decimal digits will be displayed.

Below that you’ll find the “Translation Table” field. This field contains the mapping from
field values that your driver returns to values which make more sense to you and your 
application. If this field is left blank, the values are reported as the driver reports them.

 As many as 255 entries can be made in this field defining the mapping of driver values to
display values. Linear interpolation is used to fill in the gaps between values. In other 
words, if you only entered two values, let’s say 0 and 5, everything else in between 
would be calculated by WinLog in a linear fashion. Let’s say 0 = 0 (display) and 5 = 100 
(display). A driver value of 2.5 would result in a display value of 50. (Since it’s half way 
between 0 and 5, and 0 and 100 display).

Values can be added or deleted from the Translation Table field by selecting the “Add” 
or “Remove” buttons to the right of the screen. Selecting “Add” will cause another screen
to appear prompting you for input and output values.

This value will then be inserted into the list (sorted automatically). To delete values from 
the list, simply select one or more of them by highlighting them, and then clicking the 
delete button.

Since there are many common conversions, you also have the ability to load and save 
configurations for specific gauges. In fact, a few common translation files are included 
with the installation of WinLog. To load a translation file, simply select the “Load” 
button and choose the file. To save your own (or modified) translation file, select the 
“Save” button and specify a filename. Note that you do not need to save the translation 
file unless you plan on giving it to someone else or just want to back it up. The program 
automatically saves the translation configuration in its own internal configuration files.

When you are done configuring devices, select the “OK” button at the bottom of the 
Configure Logging Device Settings screen, and you will be returned to the WinLog main 
screen, and an empty “dashboard”. Note that if at some point, you need to reconfigure the
logging device, simply select the logging device in the “Configure Logging Device 
Settings” screen, and click the “Settings” button. Doing so, will cause the device 
configuration dialog to be displayed, allowing you to modify the device settings.
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At this point, you could begin logging the data coming from your logging device to a file,
there’s no requirement to have gauges displayed in order to log data, but most people will
most likely want to see what’s going on in real-time, so let’s talk about how to build a 
dashboard.
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Configuring the Dashboard

The “dashboard” feature of WinLog allows you to actively display data as it is coming 
back from your logging device(s).  In fact, even if you are not logging data, you can 
simply display the “live” data from your logging device(s) on the screen in real-time. The
dashboard is composed of one or more (up to 64) “gauges”. 

A gauge is added to the dashboard by selecting the Edit->Add menu item from the main 
screen. Once selected, you will be presented with the “Add a new item to the dashboard” 
screen:

From this screen, you can select which type of gauge (or button) that you would like 
added to the dashboard. This is done by highlighting an item in the list, and selecting the 
“Next >>” button.  After selecting the “Next” button, the gauge specific options will be 
displayed for you to configure. We’ll talk about the specifics of each gauge shortly.

When a gauge is initially created, it is placed in the upper left hand corner of the 
dashboard. The gauges size and position are defined by the user by dragging them around
with the mouse (or cursor keys). When a gauge is selected, the dashboard display is 
paused while the user is editing the gauge and its settings. To un-pause the dashboard 
display, simply click on the dashboard background, or select the Edit->Deselect Gauge 
menu item.

When a gauge has been selected, a selection rectangle will be displayed around the 
gauge:
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Clicking and dragging the gauge (by holding down the mouse button) will cause the 
gauge to move. Clicking and dragging the “handles” (the slightly larger black rectangles) 
at the corners and sides of the gauge will cause the gauge to resize. In addition, the 
keyboard can be used to fine position/size the gauge. Using the cursor keys, you can 
move the gauge up/down/left/right a single pixel at a time. Holding the shift key down 
and using the cursor keys will cause the gauge to be resized a single pixel at a time. 
When you are done editing the gauge, click the “blank” area of the dashboard, and the 
gauge will begin updating.

The following gauges are available for building your dashboard:

Analog Gauge (Classic)

This Analog gauge is a simple sweep gauge that allows you to display your data in an 
“Analog Style”. It has the ability to define colors around the dial area of the gauge, 
displays the “units” and also has a digital display of the current value. Selecting the gauge
and selecting the Edit -> Properties menu item will display the gauge settings:
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This screen lets you configure the analog gauge settings. At the top of the screen is the 
“Title” field. This is the text that will be displayed at the bottom of the analog gauge. 
Note that if you would like to have this gauge to be able to display “warnings” that the 
gauge *must* be given a title. If you prefer to not have a title displayed, you can leave 
this field blank.

The “units” field allows you to display a unit of measure in the middle of the analog 
gauge. This field is not required, and if left blank will not be displayed.

The “Data Source” field is the field that drives the display of this gauge. Clicking on the 
small “…” button at the right of the gauge will present you with the list of fields that can 
be selected from to drive the gauge.

Select a field from the list by clicking on the field (not the device!), and select the “OK” 
button. You will be returned to the gauge configuration dialog, and the “Data Source” 
field will be filled in with the newly selected field.
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The “Precision” field allows you to select the number of digits following the decimal 
point in the analog gauges displayed numbers, around the dial, and in the digital portion 
of the gauge. Setting this value to zero will omit the display of the decimal point and the 
trailing precision.

The “Average Display” field allows you to average samples as they are received from the
logging device. If the field is extremely “noisy” this setting can help by smoothing the 
display. Setting the field to zero disables averaging.

The “Minimum and Maximum Value” fields are the range of values that the analog gauge
will display. 

The “Color Ranges” field defines ranges of colors that will be displayed around the bezel 
of the analog gauge. The color, range, and number of ranges that will be displayed are 
completely user definable. Note that when you define a single range, the rest of the range 
is displayed in black by default. If you’d like it to look like the default gauge 
configuration, simply add a range for the remaining portion of the gauge, and set it to 
“white”

Selecting the “Add” button next to the color ranges will allow you to add a new color 
range. The following dialog is displayed when you selected “Add…”

These settings define the range and color that will be used to display in the bezel of the 
analog gauge. 

First, specify the values that will be used for the bezel color range. Range min is the start 
value for the color, and range max is the end value for the color.

Next, select the color (by clicking on the color box), clicking the color box will display 
the color chooser dialog:
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When the color has been selected, click the OK button to return the Color Range dialog. 
Select the “OK” button on the color range dialog to return to the analog gauge 
configuration dialog.

Selecting the “Edit” button will allow you to modify both the range and color for the 
color range. It displays the “Color Range” dialog for the selected color range.

Selecting the “Remove” button will delete one or more selected items from the “Color 
Ranges” field. 
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Analog Gauge (New)

This Analog gauge is a simple sweep gauge that allows you to display your data in an 
“Analog Style”. It has the ability to define many visual appearance attributes of the 
gauge. In addition, user bitmaps can be specified to make completely custom gauges. 
(There are a few bitmaps installed with winlog that you can use as gauge backgrounds, 
check them out in the winlog install directory.)  Selecting the gauge and selecting the Edit
-> Properties menu item will display the gauge settings:
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The Edit Analog Gauge Parameters screen lets you configure the analog gauge settings. 
Clicking on any of the settings will cause it's description to be displayed in the box at the 
bottom of the screen. Double clicking a setting will bring up a dialog that allows the 
setting to be modified.
Following is an overview of the settings that are available for the Analog gauge. For a 
description of individual settings, simply click the setting, and it's description will be 
displayed in the description field at the bottom of the settings dialog.

The “Data Source” field is the field that drives the display of this gauge. Clicking on the 
small “…” button at the right of the gauge will present you with the list of fields that can 
be selected from to drive the gauge.

Select a field from the list by clicking on the field (not the device!), and select the “OK” 
button. You will be returned to the gauge configuration dialog, and the “Data Source” 
field will be filled in with the newly selected field.

Gauge Bitmaps 
The bitmap file that will be displayed for the gauge. This bitmap will be displayed under 
the gauge needle and optionally the gauge numbers/divisions/and range markers. This 
bitmap can contain “transparent” areas by selecting a transparent color in the 
configuration options. By default, the transparent color is Red=255, Green=255, 
Blue=254, RGB values that contain that color will not be displayed.

Gauge Label - This is the text that will be displayed for the analog gauge. Note that if you
would like to have this gauge to be able to display “warnings” that the gauge *must* be 
given a title. If you prefer to not have a title displayed, you can leave this field blank.

Start/Sweep Angles - The angle of the needle at the gauge start position (in degrees, with 
0 degrees located at the bottom of the gauge), and how far the gauge sweeps (also 
specified in degrees).

Divisions – Divisions refer to the tick marks that represent the scale of the gauge. Major 
divisions are the “larger” divisions that are displayed on the scale. If you don't need the 
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gauge to display divisions (maybe because you're using a bitmap that already has the 
scale on it), simply set the divisions values to zero, and they will not be drawn.

Sizes/Lengths – In general, sizes and lengths of gauge elements are specified in one of 
two units of measure, either in pixels, or as a percentage (0-100) of the diameter of the 
gauge.

Range Markers – These are colored areas of the gauge that are useful for marking 
warning regions etc (for example, a “redline” of a tachometer).  Up to three ranges can be
defined for each gauge, each with a user defined color.

Digital Gauge

The digital gauge is a simple digital gauge which displays either numeric or textual 
values on the dashboard.  As with other gauges, it is resizable, the font sizes will grow 
proportionally to the gauge size.

When the digital gauge is displaying numeric values, it also has the ability to display 
peak/hold values, which are displayed at the left hand side, the high (peak) value is 
displayed at the top, and the low value is displayed at the bottom.

Editing the properties for the digital gauge will present you with the “Configure digital 
gauge” dialog:

At the top of the screen is the “Title” field. This is the text that will be displayed at the 
top of the digital gauge. Note that if you would like to have this gauge to be able to 
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display “warnings” that the gauge *must* be given a title. If you prefer to not have a title 
displayed, you can leave this field blank.

The “Data Source” field works as in the Analog gauge configuration, simply select the 
“…” button to select the data source for this gauge.

The “Precision” field allows you to select the number of digits following the decimal 
point in the gauges displayed numbers, including the peak/hold values, if displayed. 
Setting this value to zero will omit the display of the decimal point and the trailing 
precision. Note that if a non-numeric (text) field is selected as the data source, this field 
has no effect.

The “Average Display” field allows you to average samples as they are received from the
logging device. If the field is extremely “noisy” this setting can help by smoothing the 
display. Setting the field to zero disables averaging. Note that if a non-numeric (text) 
field is selected as the data source, this field has no effect.

The “Show Peak Hold” check box enables and disables the peak/hold display, and the 
time that the peak/low values are displayed are defined by the “Peak/Hold Time” field, 
which is defined in seconds. Note that if a non-numeric (text) field is selected as the data 
source, this field has no effect (and peak/hold values are not displayed). The peak and 
low values for each gauge will be displayed for the specified number of seconds (unless 
that peak or low is exceeded, then the new value will be displayed). This feature can be 
useful for glancing at the gauge and seeing what the peak/low values for that gauge were 
for the last ‘n’ seconds (‘n’ being specified by this configuration item). Note that 
averaging does *NOT* apply to peak/hold values, this way, you can keep track of the 
true peak/low values even though the main gauge display might have averaging disabled.

Note: Setting the peak/hold time field to -1 will cause the peak/hold values to be held 
indefinitely.
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Bitmap Gauge

The bitmap gauge is a gauge that allows you to display various user defined bitmaps in 
response to changing logging device fields. Below is an example of a gauge that changes 
from red to yellow to green in response to changing input values. There are a few bitmaps
installed with winlog that you can use, check them out in the winlog install directory.

 Up to 16 different ranges/bitmaps can be defined for the bitmap gauge. This gauge can 
be useful for displaying various states based on an input field value. Editing the 
properties for the bitmap gauge will display the Configure Bitmap Gauge dialog:

The configure bitmap gauge dialog lets you specify the bitmaps that will be displayed for 
the gauge for various input value ranges. Up to 16 ranges/bitmaps may be defined for 
each bitmap gauge. Ranges can be added to the list by clicking the “Add” button, after 
which the Bitmap Range Configuration dialog wil be displayed:
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The bitmap range configuration dialog allows you to specify a range for which a specific 
bitmap will be displayed. Clicking the “...” button will allow you to choose a bitmap for 
the range defined.

Ranges may also be edited (by double clicking the range, or by highlighting it and 
clicking the “Edit” button). Finally, ranges may be deleted from the list by highlighting 
them, and clicking the “Delete” button.

Additional settings for the Bitmap gauge are displayed by selecting the “Settings...” 
button, which displays the “Edit Parameters” dialog:

The edit parameters dialog lets you edit the following parameters for the bitmap gauge:

The “Data Source” field works as in the Analog gauge configuration, simply select the 
“…” button to select the data source for this gauge.

The “Average Samples” field allows you to average samples as they are received from 
the logging device. If the field is extremely “noisy” this setting can help by smoothing the
display. Setting the field to zero disables averaging.

The “Default Bitmap” field allows you to specify a bitmap that will be displayed by 
default (that is, a bitmap that is displayed when the input value falls outside of all of the 
user defined ranges)

The “Warning Bitmap” field allows you to specify a bitmap that will be displayed 
whenever a warning has been triggered. (See the Warnings section later on in this guide 
for details about configuring warnings)

The “Gauge Label” field allows you to define the identifier for this gauge, it must be 
defined for the gauge to display warnings. This label is not displayed anywhere on the 
bitmap gauge, and is only used to identify the gauge.
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The “Transparent Color” field allows you to define a transparent color for your bitmaps. 
The defined color will not be displayed by WinLog.

Bar Gauge

The bar gauge is a rectangular gauge which can display numeric values, and associate 
them with a percentage or color. It displays a bar and overlays the bar with the current 
value.

Editing the properties for a bar gauge will display the “Configure Bar Gauge” dialog:

At the top of the screen is the “Title” field. This is the text that will be displayed at the 
top of the bar gauge. If you prefer to not have a title displayed, you can leave this field 
blank.

The “Data Source” field works as in the Analog gauge configuration, simply select the 
“…” button to select the data source for this gauge.

The “Precision” field allows you to select the number of digits following the decimal 
point in the gauges displayed numbers. Setting this value to zero will omit the display of 
the decimal point and the trailing precision.

The “Average Display” field allows you to average samples as they are received from the
logging device. If the field is extremely “noisy” this setting can help by smoothing the 
display. Setting the field to zero disables averaging.

The “Minimum and Maximum Value” fields are the range of values that the bar gauge 
will display, the minimum value at the left, and the maximum at the right.

WinLog v1.1 25



The “Start and End Color” boxes define the color that will be used to define the color bar 
that will be displayed in the gauge. Click each of the color boxes to define the colors that 
will be used. If both colors are the same, a single color bar will be displayed. If the colors
are different, a color gradient will be displayed.
Scrolling Graph Gauge
The scrolling graph displays data as it is received in real time (and scrolls it to the left as 
more data is received). This data is not saved (unless logging is enabled). The graph 
display can be temporarily paused by clicking on it, but the live graph cannot be scrolled 
around or used to review data that is not currently being displayed. To review logged 
data, the data must be logged to file, and can be reviewed by opening the log file with 
either WinLogView or another log file viewing application. For more information on 
reviewing data, please see the “Reviewing Log Data” section further on in this document.

The appearance and settings of the live graph can be modified to suit your needs. Things 
like graph colors, ranges, and whether or not decimal values (floating point) should be 
displayed can be configured for each gauge graph.

Selecting Edit->Properties for the real-time scrolling graph will display the following 
dialog:
 

At the top of the screen is the “Title” field. This is the text that will be displayed at the 
top of the scrolling gauge. Note that if you would like to have this gauge to be able to 
display “warnings” that the gauge *must* be given a title. If you prefer to not have a title 
displayed, you can leave this field blank.
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The fields list contains the list of fields that will be displayed in the scrolling graph. Up to
12 fields may be displayed in each scrolling graph (note that you may have multiple 
scrolling graphs on the same dashboard). 

Clicking on the “Add” or “Properties” button (when an item is selected) presents you 
with the configuration options for each field:

The “Data Source” field works as in the Analog gauge configuration, simply select the 
“…” button to select the data source for this gauge.

The “Precision” field allows you to select the number of digits following the decimal 
point in the legends display values. Setting this value to zero will omit the display of the 
decimal point and the trailing precision.

The “Average Display” field allows you to average samples as they are received from the
logging device. If the field is extremely “noisy” this setting can help by smoothing the 
display. Setting the field to zero disables averaging.
 
The “Minimum and Maximum Value” fields are the range of values that the scrolling 
gauge will graph; values outside of the range will be truncated to the top and bottom of 
the graph.

The “Graph Color” box defines the color that will be used to plot the field in the graph, 
clicking on the color box will allow you to select a color for the graph. Colors are 
automatically selected by WinLog so that a color conflict does not occur.

Select the OK button when you are done defining the settings for the field, and you will 
be returned to the Configure Scrolling Graph dialog.

The “Remove” button allows you to remove one or more fields from the scrolling graph, 
fields that have been selected in the fields list will be deleted when this button is clicked.

When warnings are triggered, and a real-time scrolling graph is selected as a gauge to 
flash, a vertical red line will be plotted at the point the warning was triggered. For more 
information on warnings, please see that section later in this guide.
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Realtime Matrix Gauge

The realtime matrix gauge allows you to display data in a “spreadsheet” style gauge that 
plots values based on two input fields, and a resulting field based on the intersection of 
the two input fields. Along each of the axes (vertical and horizontal), an input field is 
selected, for each of the cells in the “spreadsheet”, the third input field is displayed. This 
type of display can be useful in things like air/fuel ratio tuning maps, where one axis can 
be manifold pressure, one can be RPM, and the cells can be the air/fuel ratio.

As data is received from the logging devices, a “cursor” is displayed, showing the current
position in the matrix (the cursor is a highlighted cell that jumps around when data is 
received). If the value received from the data logger is not contained in the matrix, the 
cursor will disappear until a valid value is once again received.
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Selecting Edit->Properties for the matrix gauge will bring up the Matrix Gauge Properties
dialog:

At the top of the dialog is the “Title” field. This is an optional title that will be displayed 
at the top of the matrix display, and if omitted, will not be displayed.

Below the title, are 3 tab style configuration pages, each corresponds to one of the three 
fields that will be used to populate the matrix.

Cell Settings:
The “Cells” tab defines the field that will be used to populate the cells on the matrix 
gauge. 

The “Data Source” field works as in the Analog gauge configuration, simply select the 
“…” button to select the data source for this gauge.

The “Minimum number of samples for a cell to be displayed” field allows you to choose 
the number of samples that must be received from the logging device before displaying a 
value. This helps keep the clutter out of the display when there are insufficient samples to
generate a valid display.

The “Discard samples with values less than” field allows you to specify a minimum 
sample field value. When the source field is less than this value, it will not be added to 
the graph (this can help keep erroneous or irrelevant data out of the matrix gauge).

The “Discard samples with values more than” field allows you to specify a maximum 
sample field value. When the source field is more than this value, it will not be added to 
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the graph (this can help keep erroneous or irrelevant data out of the matrix gauge). Note 
that this field defaults to zero, and if not set might result in data not being displayed!!!

The “Precision” field allows you to select the number of digits following the decimal 
point in the cell display values. Setting this value to zero will omit the display of the 
decimal point and the trailing precision.

The “Display” setting allows you to choose the matrix gauge display mode; the following
three settings are available:

Average – The samples received from the device will be averaged and displayed in the 
cells
Minimum – The minimum value received from the device will be displayed in the cells
Maximum – The maximum value received from the device will be displayed in the cells.

The “Average Samples” field controls the number of samples that will be averaged 
before discarding samples. This allows a “rolling” average to be used, causing only 
“recent” samples to be included in the display, discarding older samples. If this value is 
set to zero, values are infinitely averaged.

The Cell Color Range fields control the background color that will be used to display 
cells.  The color will be interpolated between the mimimum and maximum defined cell 
values using the specified colors for the span. The following fields are available:
Start Color Cell Value – The value of the starting sweep color. Cell values less than the 
specified value will all be displayed using the starting sweep color.
End Color Cell Value – The value of the ending sweep color. Cell values greater than 
the specified value will all be displayed using the ending sweep color. 

The starting and ending colors can be changed by clicking on the color boxes, and 
selecting a color. If the start and end colors are the same, the selected color will always 
be used as the background color for the cell.
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Row/Column Settings
The row/column setting tabs define the x and y axis data fields. The settings for rows and 
columns are identical, so both will be discussed here.

The “Data Source” field works as in the Analog gauge configuration, simply select the 
“…” button to select the data source for this gauge.

The “number of cells” field defines the number of rows/columns in each axis. Adding 
additional rows/cols to the gauge is accomplished by making this number larger or 
smaller.

The “Cell Ranges" field defines the range of each row/column in the gauge. The ranges 
do not need to be contiguous (i.e., there may be gaps in the ranges for areas that you are 
not interested in). Overlapping cell ranges will only display values in the first cell range 
that is defined. To modify a cells range, simply double click on the one of the ranges in 
the list, and specify the minimum and maximum values for that cell. Double clicking an 
item presents the Row/Col range dialog:

The “Range Min” field defines the minimum value for the specified row/col. (the current 
row/col is displayed in the title bar of the dialog)
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The “Range Max” field defines the maximum value for the specified row/col (the current 
row/col is displayed in the title bar of the dialog)

Pressing the “OK” button will return you to the configure matrix dialog.

If you need to delete one or more rows/columns, simply change the “Number of Cells” 
field, and the number of fields will be updated accordingly.

The “Precision” field allows you to select the number of digits following the decimal 
point in the row/column display values. Setting this value to zero will omit the display of 
the decimal point and the trailing precision.

The “Display” setting allows you to choose the matrix gauge display mode; the following
three settings are available:

Range – The range (both min and max values) of row/column values will be displayed in
the header.
Minimum – The minimum value for the cell will be displayed in the header
Maximum – The maximum value for the cell will be displayed in the header.

The “Average Samples” field controls the number of samples that will be averaged when 
determining the current active row or column. Setting this value to zero will disable row/
column averaging. If you find that the cursor is bouncing around too much, try increasing
the value in this field.
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Function Button

The function button is not a “gauge” but instead a user interface element that can be 
added to the display in order to control certain functions of WinLog and your logging 
device(s). Its main intention was to facilitate easier touch screen use. The user can setup 
large, easy to read (and touch) buttons on the screen to do things like start/stop logging, 
view the last log etc.

The Edit->Properties menu allows you to change aspects of the function button. When 
selected the “Configure Function Button” is displayed.

The “Title” field determines the text that will be displayed on the function button. If 
desired, it can be left empty.

The “Set Shortcut Key…” button allows you to define a shortcut key to execute the 
button function. When the key is pressed, the function button will be “executed”. 
Clicking this button causes the “Configure Keyboard Shortcut” dialog to be displayed. 

When this dialog is displayed, simply press the key that you would like to define as your 
shortcut, and you will be returned to the Configure Function Button dialog. If you would 
like to clear the shortcut key, simply press the “Clear” button, and no shortcut key will be
defined for the function button.
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The “Functions” field defines the functions that will be executed when the button is 
clicked, the field list may contain multiple devices and function calls.

The “Device” field contains the name of the device that the function will be called from.
The “Function” field is the name of the function that will be called.
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Clicking the “Add” button will cause the “Select Function” dialog to be displayed: 

This dialog displays the functions that are available for WinLog to call. Some standard 
functions are always included in this list:
New Datalog – Cause WinLog to create a new data log, stopping any current logging 
session (This is the same as selecting File->New Datalog)
Stop Logging – Stop the current log to file and close the file (Same as File->Stop 
Logging)
Open Datalog – Open a data log file (Same as File->Open Datalog)
Open Last Datalog – Open the last (or currently logging) data log file (Same as File-
>Open Last Datalog)
Set Marker In Datalog - If you are currently logging to a file, and the “Enable Log 
Markers” option has been enabled, this menu item will cause the marker field to be set to 
‘1’ for the current sample in the log file.
Next Dash – Selects the next dashboard page (Same as Edit->Next Dash)
Previous Dash - Selects the previous dashboard page (Same as Edit->Previous Dash)

In addition, your loaded drivers *may* present device options in this list. 

When you have selected a function to add to the list, click the OK button and you will be 
returned to the “Configure Function Button” dialog.

The “Remove” button removes selected functions from the function list.
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Sample of a configured dashboard
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WinLog Menu Items
The WinLog menu items are the main user interface to WinLog, the menu items are 
described below:

File Menu

The file menu controls most of the “File” type operations in WinLog, such as 
starting/stopping logging, and opening/saving dashboard files.

New Datalog
The New Datalog menu item creates a new data log file, and starts logging data from 
attached devices that file. Depending on the logger settings, a file selection dialog will be 
displayed asking you to choose a filename. If the logger is setup to automatically 
generate filenames, logging will be started automatically when this option is selected. If a
file is currently being logged, that file will be closed, and logging will begin to the new 
file.

Stop Logging
The Stop Logging option causes the logger to stop logging data to file.
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Open Datalog
The Open Datalog menu item causes WinLog to display a file selection dialog for you to 
choose a data log to display. 

Once selected, WinLog will launch the log viewing application (defined in Logger 
Settings, which, by default, is WinLogView). Logging *will* continue if logging is 
currently active.

Open Last Datalog
The Open Last Datalog menu item causes WinLog to open the last (or current) data log 
file (as with the open dialog, the viewer defined in the logger settings will be used to 
view the file). If logging is currently active, it will be stopped, and the resulting log file 
will be reviewed. If logging is not currently active, the last created log file since the 
program was started will be opened. 

New Dashboard
Selecting this option will create a new, empty dashboard. If the current dash has been 
changed, you will be prompted to save it prior to creating the new one. 
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Open Dashboard
Selecting this option allows you to load a dashboard from a file. When selected, a file 
selection dialog will be displayed, allowing you to choose the dashboard file. 

WinLog automatically remembers the last opened dashboard file, and will display that 
dashboard the next time it starts.

Save Dashboard
Allows you to save the currently loaded dashboard (if it was opened from a file). 

Save Dashboard As…
Allows you to save the current dashboard to a new filename.

Exit
Stops all logging, and exits WinLog. If the current dashboard has been modified, you will
be prompted to save it prior to exiting.
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Edit Menu

The Edit menu relates to setting up most of the options of the current dashboard, 
warnings, and WinLog settings:

The first section of the edit menu relates to the dashboard and gauges. 

Add
The Add menu item adds a new gauge to the current dashboard. When selected, the 
“Select Gauge Type” dialog will be displayed, and a new gauge will be added to the top 
left hand corner of the dashboard, at which point the user can drag the gauge to a suitable 
location.

Properties
Allows the user to edit the properties of the currently selected gauge.

Delete
Deletes the currently selected gauge from the dashboard

Copy
Copies the currently selected gauge to the clipboard This allows easy copying of gauges 
between dashboard files, and duplication of similar gauges.

Paste
Pastes the currently selected gauge to the clipboard. This allows easy copying of gauges 
between dashboard files, and duplication of similar gauges. Once a gauge has been 
pasted, it can be modified like any other gauge.

Deselect Gauge
Deselects the currently selected gauge, and un-pauses the dashboard. Useful when your 
gauges completely cover the dashboard background, and you cannot click it to unpause 
the dashboard display.

Set Datalog Marker
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If you are currently logging to a file, and the “Enable Log Markers” option has been 
enabled, this menu item will cause the marker field to be set to ‘1’ for the current sample 
in the log file.

Note: The marker command could also be assigned to a shortcut key by creating a 
function button that includes the “Set Marker” command, and assigning a shortcut key to
that function button. (See the “Function Button” section for more information on 
functions and shortcut keys)
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View Menu

Next Dash
This option displays causes WinLog to display the next dashboard defined in the 
“dashboard pages” setting, which is defined in the Dashboard Settings dialog. If no ‘next’
dash is available, the dashboard will not be changed. This option can be useful if you 
frequently need to change between one or more defined dashboards.

Previous Dash
This option displays causes WinLog to display the previous dashboard defined in the 
“dashboard pages” setting, which is defined in the Dashboard Settings dialog. If no 
‘previous’ dash is available, the dashboard will not be changed. This option can be useful
if you frequently need to change between one or more defined dashboards.

Device Configuration
The device configuration menu item allows you to setup and configure the devices 
attached to WinLog. When selected, the “Configure Logging Device Settings” dialog will
be displayed. Note that selecting this option will cause the current log file to be closed!

Log Configuration
This option displays the log configuration settings dialog to be displayed, See that section
later for more information about log settings.

Dash Configuration
This option displays the general WinLog Dashboard settings dialog to be displayed, See 
that section later for more information about log settings.

Warning Configuration
This option causes the warnings configuration dialog to be displayed. See that section 
later for more information about warnings.

Full Screen
This option causes WinLog to be displayed in Full Screen mode. To exit full screen 
mode, press the <ESC> key.
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Log Settings

The following options are available on the Configure Logging Options screen:

Automatically Generate Log Filename
Selecting this option causes WinLog to automatically generate the log filename, and start 
logging when the File->New Datalog option is selected. If this option is not selected, the 
user will be prompted for a filename each time a new log file is created. 

Automatically generated log filename path
This is the directory that automatically generated log filenames are stored. If this field is 
blank, the application directory will be used to store log files.

Log Viewer
This is the viewer that will be launched by WinLog when the “Open Logfile” or “Open 
Last Logfile” option has been selected.  If this field is blank, WinLog will attempt to use 
WinLogView to display the log file.

Logging Rate Options
The Logging rate options determine how samples are logged to file when they are 
received from the logging device.

There are two logging modes:

Log samples as they are received from the logging device(s)
Selecting this option causes WinLog to add every sample to the log file as it is received 
from the logging device(s).  Because of this, logging devices with more frequent update 
rates can cause repetition of data from devices that have slower update rates.
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Log at a fixed sample rate
This causes WinLog to gather data from the logging device(s), and log them to the log 
file at the specified sample rate (default is 100ms). The last value received at each 
interval will be added to the log file for each device.

Enable Log Markers
This causes WinLog to add an additional field to the log file named “Marker”.  When the 
marker field is present, WinLog allows the user to “Tag” the log file with a marker at any
time while logging is active by selecting the Edit->Set Datalog Marker option. The 
logfiles “Marker” field will contain a ‘1’ for the sample when the marker was selected, 
and a ‘0’ when it is not. 

WinLog v1.1 44



Dashboard Settings

The following options are available on the Dashboard settings screen:

Gauge Update Rate
The display update rate determines how fast the gauges are updated on the dashboard. 
The default value is 100ms (updates occur 10 times every second). On some slower PC’s 
this value may need to be increased in order to work well on the specific PC. On a P233 
values down to 20ms have been tested successfully. You’ll find that updating too 
frequently causes the live graph to become less useful (since the data scrolls off the 
screen so quickly). This setting in no way affects the sample rate of the actual logged 
data; it only affects how fast it is reflected on the screen. Logged data is always stored at 
the speed specified under the Logging Rate settings.

Pages
This list defines the “pages” that can be accessed by the next/previous dashboard 
commands on the Edit menu. To add pages to this list, simply use the add or insert 
buttons below the list. To remove a page from the list, select it, and click the “Remove” 
button. (Note that this will not delete the dashboard, only remove it from the dashboard 
page list).

Background Color 
This option specifies the background color of the dashboard. Clicking the color box will 
present you with the color chooser dialog to choose a new color for the background.
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Background Bitmap
This option specifies a bitmap that will be displayed as a “wallpaper” inside of WinLog.  
If the field is empty, no bitmap will be displayed. Clicking on the “...” button next to the 
field will allow you to choose a bitmap file. There are a few bitmaps installed with 
winlog that you can use as background bitmaps, check them out in the winlog install 
directory.

Alignment
Configures how the wallpapers bitmap will be displayed, either tiled, centered, or 
stretched to fit the entire window.
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Warnings
The warnings screen allows you to define one or many conditions in which to signal you 
that some event has occurred. The warning definition scheme used by WinLog allows 
you to define a warning condition with one or many parameters, allowing you to more 
accurately describe the condition. (Since some environments can be quite dynamic, 
usually more than one sensor is required to define an actual warning condition.) 

To begin defining a warning, select the “Edit->Warnings” menu item on the main screen. 

On the warning screen is a list of the current warnings that will be monitored

To define a new warning condition, click the “Add” button. Once the “Add” button has 
been clicked the “Define Warning” screen will be displayed. 
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First, you’ll want to give your warning a name. Do this in the “Name” field at the top of 
the screen. It should be a name that describes the entire warning condition. 

Next, you’ll add all of the conditions that must be satisfied in order to trigger this 
warning. To add a new condition to the definition, select the “Add” button to the left of 
the conditions field. The following dialog will be displayed:

Data Source
The data source defines the field that this condition will be monitoring. The “Data 
Source” field works as in the Analog gauge configuration, simply select the “…” button 
to select the data source that will be used to trigger this warning.
The “Is” field defines the evaluator for the trigger condition:
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The following options are available
Less Than – If the received value is less than the specified value, the warning will be 
triggered
Greater Than– If the received value is greater than the specified value, the warning will 
be triggered
Equal To– If the received value is equal to the specified value, the warning will be 
triggered
Between Range– If the received value is between the ranges of the specified values, the 
warning will be triggered
Outside of Range– If the received value outside of the range of the specified values, the 
warning will be triggered

For the last two options in the conditions list, an extra field will be displayed to specify 
the valid numeric range.

When you have completed defining the condition, select the “OK” button to return to the 
Define Warning Dialog, and your new condition will be present in the definition list.

The “Edit” and “Remove” buttons next to the definition list allow you to edit the 
currently selected condition, and the Remove button allows you to delete the selected 
conditions from the definition list.

Conditions that refer to logging devices that are not currently available will be “grayed 
out” in this list, this is simply a mechanism to draw your attention to items that might 
cause a warning to not trigger. 

Mode
The Mode option allows you to specify if one or all of the conditions in the definition 
must be met in order to trigger the warning.

Warning Notifications
Obviously, it’s nice for you, the user to know that a warning has been triggered. You 
have two options at your disposal for knowing that a warning has been triggered. The 
first is the ability to “Flash” one or more gauges. When the warning is triggered, the 
specified gauge will flash red, and stay red for a few seconds. In addition, you can have 
WinLog play a wave file, which may help when you have your eyes on the road. To play 
a wave file when the warning is triggered, select a file by clicking the “…” option at the 
bottom of the screen. To verify the wave file works, you can press the “Play” button at 
the bottom of the screen to play it immediately.
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In addition, the main screen displays the number of warnings that have been triggered in 
the field at rightmost portion of the status bar, this is a running total of the triggered 
warnings.
 
The flash gauges list is defined by selecting the “Add” and “Delete” buttons next the 
“Flash Gauges” field. Selecting the “Add” button displays the “Select Gauge” dialog.

The select gauge dialog displays gauges that can be selected to be flashed when a 
warning is triggered. Currently, only analog, digital, bitmap, and scrolling gauges can be 
selected to be flashed. In the case of the scrolling graph, a red marker is inserted into the 
graph when a warning is triggered. For the Analog and Digital gauges, they are flashed 
“red” for approximately 5 seconds after each warning is triggered.

In addition, in order for a gauge to be flashed, the gauge *MUST* have a title, otherwise 
WinLog cannot identify the gauge. If you’re looking for a gauge to flash, and don’t find it
in this list, check to be sure that the gauge has a title!

When you have selected the gauge you would like to flash, select the “OK” button, and 
you will be returned to the Define Warning dialog.

The “Delete” button allows you to remove selected gauges from the “Flash” gauges field.

Items that are “grayed out” in the Flash Gauges field refer to gauges that are not currently
available in the current dashboard, and thus will not be flashed.

Add a field to the log file for this warning
This option allows you to add a field to the log file for the currently defined warning. 
When this option is checked, the name of the warning will be used as a new field in the 
log file. When the warning is not triggered, a value of 0 will be put in the log field. If the 
warning has been triggered, a value of 1 will be put in the log field.

Start Logging when warning is triggered
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This option allows you to automatically start logging when a warning has been triggered. 
For best results, combine this option with the “Automatically generate log filename” 
option in the logging options. If auto name file generation has not been selected, the 
logging may not start since WinLog needs to wait for the user to enter a filename.

Stop Logging when warning is triggered
This option allows you to automatically stop logging when a warning is no longer 
triggered. 

Trigger Hysteresis
This option allows you to set the hysteresis for the warning to trigger. At least the number
of specified samples must meet the trigger conditions before the warning is triggered. 
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Log Files
Log Files are stored in an ASCII CSV (comma separated values) format. When the auto 
generate filenames option has been selected, the naming convention for the files is based 
on the current date and time, with a .txt extension. 

The first line in the log file contains the identifier (WinLog and its version number) 
followed by the website name.

The second line in the log file defines the field names that are in the log file, separated by
commas.

The third through the end of file lines contain the actual log data, comma separated.

These file should be able to be opened in most any application, good examples are 
notepad, Microsoft Excel, Open Office and WinLogView (included!).
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WinLog Virtual Driver
The WinLog virtual driver is a special driver that is included with WinLog that allows 
you to define custom fields which are derived from other loggers fields using 
mathematical expressions.

In order to use the WinLog virtual driver, go to the View->Device Configuration menu 
and select the “Add...” button in the Configure Logging Devices dialog. Then select the 
WinLog Virtual Driver. After selecting the driver you will be able to configure it. 

The Virtual Driver allows you to define up to 10 new fields that can be displayed and 
logged by WinLog just like other driver fields. In the configuration dialog, you are 
presented with the list of fields that will be available to WinLog to log/display, you can 
add, delete, and edit fields that you have defined.

Defining a new field

To define a new field for WinLog to Log/Display, click the “Add” button from the 
configuration dialog and you will be taken to the configure virtual field dialog:

In this dialog, you define the attributes of the new logger field. The following attributes 
of the field are defined in this dialog:
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Field Name

The field name box lets you define the name for your new logging field, in general, this 
should be a unique name that identifies the function of the field. If the name that you 
enter matches another field (in another device), WinLog will automatically modify the 
name of the field for you so that it is different (by adding a numeric identifier to the end 
of the field name).

Field Type

Defines the type of output value that this field represents, this can be either a Floating 
Point value or an Integer value. The result of the field expression will be converted to this
type before being reported to WinLog.

Field Expression

The field expression defines the mathematical function of the field. This can be 
something as simple as a fixed value, in which case the field will always contain the same
value, or something much more complex, which contains expressions based on multiple 
WinLog fields and arithmetic operators. To make it simple to add other WinLog fields to 
your expression, you can click the “Add Variable” button to add a WinLog field to your 
expression. When you click the “Add Variable” button, the Select Field dialog will be 
displayed:

This dialog will contain the names of other fields that can be inserted into your field 
expression. Simply highlight the variable that you would like to be inserted and click the 
OK button, at which point the name of the variable will be inserted into the Field 
Expression text box. Note that all WinLog fields must be surrounded by quotes in order 
for WinLog to identify the field. 
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Sample Field Expressions

Following are some sample field expressions:

"Sample Winlog Driver - sample integer field" * 2

This expression would take the field “Sample Integer Field” from the “Sample Winlog 
Driver” and multiply it by 2, the result would be stored in the defined field name.

"Sample Winlog Driver - sample integer field" + "Sample Winlog Driver - sample 
floating point field"

This expression would add the “Sample Integer Field” and the “Sample Floating Point 
Field” and store the result in the defined field name.

("Sample Winlog Driver - sample integer field" + "Sample Winlog Driver - sample 
floating point field") / 2

This expression would add the “Sample Integer Field” and the “Sample Floating Point 
Field”, then divide the result by two, and store the result in the defined field name.
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Field Expression Functions and Operators

Following is the list of functions and operators that can be used in the Field Expression:

Functions

Name Arguments Function

sin 1 sine function

cos 1 cosine function

tan 1 tangens function

asin 1 arcus sine function

acos 1 arcus cosine function

atan 1 arcus tangens function

sinh 1 hyperbolic sine function

cosh 1 hyperbolic cosine

tanh 1 hyperbolic tangens function

asinh 1 hyperbolic arcus sine function

acosh 1 hyperbolic arcus tangens function

atanh 1 hyperbolic arcur tangens function

log2 1 logarithm to the base 2

log10 1 logarithm to the base 10

log 1 logarithm to the base 10

ln 1 logarithm to base e (2.71828...)

exp 1 e raised to the power of x

sqrt 1 square root of a value

sign 1 sign function -1 if x<0; 1 if x>0

rint 1 round to nearest integer

abs 1 absolute value

min var. min of all arguments

max var. max of all arguments

sum var. sum of all arguments

avg var. mean value of all arguments
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Operators

Operator Meaning Priority

= assignement -1

&& logical and 1

|| logical or 2

<= less or equal 4

>= greater or equal 4

!= not equal 4

== equal 4

> greater than 4

< less than 4

+ addition 5

- subtraction 5

* multiplication 6

/ division 6

^ raise x to the power of y 7
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