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This document describes the TechEdge v1.5 and v2.x Device drivers for use in WinLog.

Many improvements have been made in the driver and main user interface of TEWBLOG 
(infact, the WinLog was created new from the ground up!). Following is the list of “big” 
changes you’ll notice if you’re a previous TEWBLOG user:

- Much improved serial Comms. CPU utilization is now 0-1% when talking to
  device, instead of TEWBLOG's old 100% all the time approach.
- Review mode now has full functionality, even in freeware version. No more sample 
limitations!
- The user can now decide what fields they would like to have logged.
- The user can now completely define the "dashboard" of gauges, move and
  size them to their liking.
- New "analog" style gauge added
- New "bar" gauge can be used for any numeric data field.
- New Realtime Matrix gauge added. Allows you to map multiple parameters
  in realtime.
- Multiple realtime scrolling graphs can be displayed, with up to 12 fields each
- The user can now re-size the main window, to better fit their display.
- User now has access to the download and clear stored data functions on the 2.x loggers
- Multiple logging devices can be connected/logged simultaniously
- The digital gauge now has the ability to display text fields, things
like the wideband status can now be displayed in a "gauge" on the screen, and logged to 
file

- The user has the option to specify the log file name, instead of having the logger
  automatically generate it.
- Configurations for gauges can now be loaded and saved, so that the user can
  have multiple logging setups, depending on what they are doing.
- Added 2J0 and 3H1 device support to the TechEdge v2 device driver
- Added 4EGT and 6User modes to the V2 TE device driver configuration
- Added L16 support for xx61 and higher firmware, no longer use IPX
  if that firmware is detected
- Added Lambda2 (for the 3h1) and VSS Volts (for the 2J0) fields to the V2 device driver 
fields.
- Touchscreen friendly, easier to use in the car with touchscreen style displays.
- Warnings (previously) alarms can now include all or just one if the conditions to be 
triggered
- The “thermistor” field is now exposed  to the user for V2.x devices that support it

V2.x Device Configuration



The TechEdge V2 driver supports all TechEdge devices that conform to the V2 packet 
structure. If you’re using a V1.5 packet device, see that section below. No additional files 
need to be installed to use a V2 techedge device with WinLog, techedge drivers are 
installed by default when WinLog is installed.

After installing WinLog, connect your device to the system, either via a COM port, or 
USB adapter (be sure that if you’re using a USB adapter, that the usb drivers have been 
installed, and that the port is working). Then run WinLog, go to the View->Device 
Configuration menu, and select the “Add…” button. This will bring up the “Select 
Device” screen, from which you should now be able to select the TechEdge WideBand 
02 (be sure to NOT select the V1.5!!!). After selecting the device, select the “OK” button.
The TechEdge V2 Settings screen will then be displayed.

TechEdge V2 Settings

COM Port
Select the COM port that the wideband device is attached to, from the COM Port field. 
This includes USB adapter virtual com ports that may be installed.

Sample Rate
The Sample Rate field defines the rate (in milliseconds) at which the wideband should 
send data back to WinLog. The default value is 100ms, which means samples will be 
generated at about 10 times per second.

Temperature Units
The “Temperature Units” field defines how the thermocouple and thermistor fields will 
be reported to WinLog, select either Deg C or Deg F

Thermocouple Fields



The “Thermocouple Fields” setting defines how the thermocouple inputs will be reported 
to WinLog. When the Report As Temperature setting is selected, the driver will report the 
thermocouple value back using a K-Type thermocouple lookup table in the units 
specified. (Deg C or Deg F). In addition, if the “Cold junction temperature 
compensation” option has been selected, the temperature will be adjusted with the value 
being reported from the devices onboard thermistor.

If the report as voltage value is selected for the “Thermocouple fields” option, the raw 
thermocouple voltage will be returned in the thermocouple field. This can be useful if 
you are using something other than a K-Type thermocouple and need to define your own 
translation table based on the thermocouple voltage.

RPM Input Sparks Per Revolution
This setting tells WinLog how many sparks are occurring for each revolution of the 
engine. It needs this in order to determine the current RPM. Common settings for this 
value are:

4 cylinder – 2 Sparks per revolution
6 cylinder – 3 Sparks per revolution
8 cylinder – 4 Sparks per revolution

Values of less than 1 can also be entered for non-standard ignitions.

VSS Triggers Per Revolution
This setting tells WinLog how many pulses occur for each revolution of the VSS input. It 
needs this in order to determine the number of revolutions per second for the VSS.

VSS Divisor
This setting is applied to the VSS revolutions per second to determine the final output 
value for the VSS field. By default, this is set to 1, resulting in the revolutions per second 
of the VSS being put into the VSS field. 
Example: Setting this value to .0167 would cause the VSS field to be reported in VSS 
revolutions per minute (1 [minute] / 60 [seconds] = 0.0167). 

Device Packet Type
Normally, this setting should be left to “Auto”, in this mode, WinLog will attempt to 
determine the device type you are using, and correctly configure the packet mode.

The TechEdge V2 driver supports many of the TechEdge Wideband datalogging devices. 
TechEdge currently has 3 types of devices that are supported by this driver. Should the 
“auto” configuration option not work, you can try the following modes:

Classic V2 – Most any techedge device will be compatible with this mode, it is the 
original V2 packet structure device



Classic V2  L16 – Very similar to the Classic V2 packet, but adds support for L16 format 
lambda values.

Extended – For devices that support the new extended packet format.

Note that the device must have version 0029b or later firmware in order to work with this 
driver. If your firmware is earlier than version 0029b, you can either upgrade your 
firmware (please see http://www.wbo2.com for details on upgrading the firmware),

There are also some advanced settings, some of which require modifications to the 
hardware:
4 EGT Mode: interprets the User3 field as an additional EGT input. Note that 
modifications to the hardware are required in order to use this input as a Thermocouple 
input.

6 User Mode: Interprets all of the thermocouple inputs as standard user inputs, the raw 
voltage of the input will be put in the thermocouple fields instead of the translated values.

No thermocouple amplification: Removes the amplification factor for the standard 
thermocouple inputs so that voltage values are correct. This requires a modification to the 
hardware to remove the hardware voltage multiplier.

Additional Device Functions
The TechEdge v2 Packet driver also supports some device specific functions that can be 
made available in WinLog.

To use the device functions, add a “function button” to the dashboard (View->Add), and 
select your TechEdge  device, and one of the following functions:

Download stored Data
Selecting this option will cause WinLog to download data to a file that is stored in the 
EEPROM of the logging device. 

Clear Stored Data
Selecting this option will cause any stored data in the logging device to be erased.

Field Configuration
After configuring the settings to your wideband, click the “OK” button, at which point 
you will be returned to the “Configure Logging Device Settings” screen. Now, you can 
go and set all of the fields up to suit your needs. First, click the click the small ‘+’ sign 
next to the device name (TechEdge Wideband O2), and the fields will be displayed 
beneath the device. By selecting a field and clicking on the “Settings” button, the field 
configuration dialog will be displayed.

http://www.wbo2.com/


One of the first things you may want to do is convert the Lambda field to something more 
meaningful to you (such as Gasoline AFR). To do this, select the Lambda field, then click 
the “Settings” button. First, put something like “AFR” in the field name box. Then Click 
the “Import” button, go to the directory where WinLog is installed (by default, this is C:\
Program Files\WinLog), and select the Lambda_to_gasoline_afr.txt file. Now you’ll see 
that the translation table is filled in with a couple of values. Now, you have a Gasoline 
AFR field that can be logged and used by the different gauges! You can continue this 
process with the other available logger fields. (such as the user inputs)

Setting up a Dashboard
The next thing you’ll do is setup the dashboard in order to monitor the data in real-time. 
(This step is optional, if you have no need to monitor the data, you can now simply log 
data). Included with the install is a “TEWBLOG” style dashboard, that emulates the old 
TEWBLOG software. If you prefer to skip defining your own custom dashboard, and just 
go straight to using WinLog like TEWBLOG, you can simply load this dashboard file. To 
load the pre-defined dashboard, goto File->Open Dashboard, select the WinLog program 
directory (by default, this is C:\Program Files\WinLog), and select the 
“tewblog_dash.dsh” file, and you should see the familiar TEWBLOG style dashboard. At 
this point you could modify the dashboard, add, or delete items from it. (Note that if you 
changed any of the field names in the “Field Configuration” section above, you'll need to 
double click the gauge, and point it to the new field name.



V1.5 Device Configuration

The TechEdge V1.5 driver supports all TechEdge devices that conform to the V1.5 
packet structure. No additional files need to be installed to use a V1.5 techedge device 
with WinLog, techedge drivers are installed by default when WinLog is installed.

After installing WinLog, connect your device to the system, either via a COM port, or 
USB adapter (be sure that if you’re using a USB adapter, that the usb drivers have been 
installed, and that the port is working). Then run WinLog, go to the View->Device 
Configuration menu, and select the “Add…” button. This will bring up the “Select 
Device” screen, from which you should now be able to select the TechEdge v1.5 
WideBand 02. After selecting the device, select the “OK” button. The TechEdge V1.5 
Settings screen will then be displayed.

TechEdge V1.5 Settings

COM Port
Select the COM port that the wideband device is attached to, from the COM Port field. 
This includes USB adapter virtual com ports that may be installed.

RPM Input Sparks Per Revolution
This setting tells WinLog how many sparks are occurring for each revolution of the 
engine. It needs this in order to determine the current RPM. Common settings for this 
value are:

4 cylinder – 2 Sparks per revolution
6 cylinder – 3 Sparks per revolution
8 cylinder – 4 Sparks per revolution

Values of less than 1 can also be entered for non-standard ignitions.

Field Configuration
After configuring the settings to your application, click the “OK” button, at which point 
you will be returned to the “Configure Logging Device Settings” screen. Now, you can 



go and set all of the fields up to suit your needs. First, click the click the small ‘+’ sign 
next to the device name (TechEdge v1.5 WideBand 02), and the fields will be displayed 
beneath the device. By selecting a field and clicking on the “Settings” button, the field 
configuration dialog will be displayed.

One of the first things you may want to do is convert the Lambda field to something more 
meaningful to you (such as Gasoline AFR). To do this, select the Lambda field, then click 
the “Settings” button. First, put something like “Gasoline AFR” in the field name box. 
Then Click the “Import” button, go to the directory where WinLog is installed (by 
default, this is C:\Program Files\WinLog), and select the Lambda_to_gasoline_afr.txt 
file (or whatever translation file makes sense). Now you’ll see that the translation table is 
filled in with a couple of values. Now, you have a Gasoline AFR field that can be logged 
and used by the different gauges. You can continue this process with the other available 
logger fields. (such as the user inputs)


